Craft your story

Dabble Community

Extra spaces in copy and paste

Hello there,

I’ve been using Dabble since late July, and I’m pretty happy with it so far. I understand the software is always being developed, so a few hiccups are expected here and there.

Something I’ve noticed when doing a copy and paste is that an extra space is added to the end of every paragraph and between every space when doing block paragraphs.

For example, the extra spaces are “shown” in brackets:

Lorem ipsum up this place, consectetur adipiscing elit. Mauris rutrum dictum massa quis dignissim.[]

[]

In vestibulum nunc ante, sit amet egestas ante suscipit eget.[]

To make things even more interesting, an extra space will show up at the beginning of random paragraphs.

I don’t know if it’s Dabble itself, or if it’s my browser. I’ve never had this show up in other writing software.

Does anyone have an idea what’s causing this and if there’s a way to fix it?

2 Likes

Typically those extra spaces happen when you use a software that uses an empty line to signify a new paragraph (typically the web and various other programs when using straight text)

SOMETIMES you can remove that extra space by using the paste as text. BUT it will only work when you are in the browser and you disable Dabbles context menus.(This is why my dabble app is the web browser version instead of the desktop version cause I need this feature)

In the case of the web sometimes you are picking up the HTML too when you copy and paste and it transfers to dabble. And sometimes the way the software applies it to the clipboard.

I know I write in markdown in a text editor with block text and extra spaces for paragraphs (per markdown) and sometimes the right click and paste as text works but other times it doesn’t. But most of the time I don’t care and just paste and just remove the extra spaces.

It is a quirk of Dabble and likely the way the rendering engine works but I don’t know the internals so can’t say for sure.

2 Likes

From a quick copy-and-paste from a plain text file into Dabble, it looks like it:

  1. Retains any leading spaces in front of paragraphs
  2. Removes trailing spaces at the end of paragraphs
  3. Retains any extra spaces between a period and the next sentence in a paragraph
  4. Retains any extra spaces between words

Now I’m using the term space loosely. I’ve wandered into some haunted forests populated by whitespace, tabs, nonbreaking spaces ( ), carriage returns, linefeeds, newlines, and any number of Unicode characters that all print like spaces.

What we can do is give @Jacob feedback on what features we would like to see in Dabble. So we need to be crystal clear what features we want and how the Dabble community would benefit from them. From the discussion Dabble should accept pasted text and process it thus:

  1. Remove any leading spaces in front of paragraphs
  2. Remove trailing spaces at the end of paragraphs. It does that now.
  3. Limit the number of spaces between a period and the next sentence in a paragraph to one
  4. Limit the number of spaces between words to one.
  5. Collapse the number of consecutive empty paragraphs to one. That includes lines with just spaces.

IMHO the above requirements make sense for a novelist. And that’s Dabble’s target audience.

1 Like

I don’t know what is causing the trailing spaces. Dabble is actually set to remove trailing spaces at the end of paragraphs, so this confuses me. If you write "This has a space " in an empty scene and cut and paste it you’ll get “This has a space” without a trailing space.

@Johannes_Rexx, that’s a good list. I’ll have to update to remove some of those other spaces on paste that exist.

Typically those extra spaces happen when you use a software that uses an empty line to signify a new paragraph (typically the web and various other programs when using straight text)

Google Docs would be the culprit, then. It’s not my preferred program, but I use it since my writing group requires it for sharing documents. Sometimes I copy and paste into Dabble (web browser) so I’ll have a proper manuscript in progress, and other times I’ll write in Dabble first and then copy and paste into Docs.

I tried using ctrl+shift+V, which doesn’t add the extra spaces at the end of sentences, but adds a paragraph break. That’s a little better.

1 Like

From what I’ve learned so far, Google Docs is the culprit. Docs isn’t my favorite program to write in. I use it for mostly convenience and because my writing group requires it for sharing documents.

I haven’t tried to copy and paste from other writing programs, but it’s probably worth experimenting with.

1 Like

You can make your google docs format like word where you on new docs.

If you manually type in a blank line it’s going to show up.

In Google Docs this looks to be the default setting (I think). But you can make it act like Word by formatting your documents with Lines and Spacing. You can simulate the blank link between paragraphs by telling it to do so. You can also save the formatting of your document to all new google docs, but I don’t remember how to do that.

I have my google docs formatted to start new docs with courier new font 12pt, 1 in margins, double spaced, a tab to start all paragraphs and no skipped lines after a return.

2 Likes

I’ll give that a try. Thank you!

1 Like