Getting Dragon to work in Dabble

Ok so I’ve been using Dabble for several months now, and I love it. Way better than anything else.

I just recently got Dragon Dictation so I could up my speed, but…I can’t get it to work in Dabble. It works in Google Docs, it works all throughout Chrome, it works in the Dragon Pad…but the one place I want it to work–Dabble–it does not. I’ve seen threads in here about people using Dragon in Dabble, but none really explain HOW they do it. They were all like “Oh I just turned it on and it worked yay! Now let me tell you how I did this other thing with Dragon in Dabble…”
Sigh. Anyone more tech-savvy than me have any suggestions?

1 Like

Wish I could help you, Constance. Hope you get it worked out.

1 Like

Hi there,
@Bella_Cooper has described in detail what she did in this post:

One thing in particular is, that she uses the Desktop version of Dabble. Or the sequence in which the programs are opened.
Try contacting her directly, I am sure, she’d be happy to help you out with this.
Regards, Chris

1 Like

I did the exact order she recommended, making sure to use the desktop version of dabble(I even tried the browser version–on the website), and nothing worked. I would love if @Bella_Cooper could share what she did in more detail, but I suspect I just need to call dragon technical support.


What issue are you having. Also, what versions of dragon and the computer and os. My set up is windows 10, dabble desktop, and i have used it with web but i find chromw has a lot of issues with it. You have to route through dragon pad.
I have a couple different microphones, my main one is a yeti.
What are you experiancing?


I had one Dabbler on Mac who had to add Dabble to an accessibility allow list in System Preferences > Accessibility. I’m not sure exactly where, it was a long time ago. Let us know if you get it figured out.

If you can’t with the desktop app, you can still use it with Chrome, and Dabble works perfectly well offline in Chrome the same as the desktop app. And with sync, you can even use Chrome just when you want to use Dragon and use the desktop app when you are doing plot work.

1 Like

So here is the exact order that works for me.

  • with nothing running dabble, dragon, etc… I boot dragon, and the mic and wait for it to get to the ready state. (for me I set that to start as sleeping in settings, but if yours is red, click to green)
  • I start up dabble desktop and get into the story and chapter.
  • I set my cursor where it should go as though I am getting ready to type.
  • I dictate to dragon via the mic (blue yeti in my case)

In the olden days, pre-dragon 13, if you didn’t start fresh, then dragon, app, and set the focus dragon did not hook into the app. It’s not a keyboard emulator in that it’s not injecting the keyboard buffer. It’s feeding the input buffer in the program that has the focus.

Now chrome had some issues recently with text areas not working properly. So dragon would not feed them the data and so the dragon notepad had to be used. But that is done by the program using the copy and paste API. Dragon Notepad is the buffer in that case. (and it was designed that way because in the day not every developer used the same coding conventions and techniques, so some programs did not directly use STDIN/STDOUT.

Hope this sequence works for you. If not I would contact dragon support and you may need to reinstall. It’s not totally unheard of that the C++ libraries dragon loads are too old or got overridden by a patched version (and stream injection could be seen as a security bug, a hotfix or patch on your system may be interfering)

You also do not mention if you are using the machine as an administrator. Many people do not. They will use a user account with lower privilege and so some functions like the ones dragon does are blocked. As a test you should try the administrator level account to see if security is playing with you. If you log into a user account normally, try logging into the administrator account and try again. Sometimes family settings can screw access like this up also. Different applications use the trust API differently and the security of where the application is installed can be vastly different. So while Word works (because Microsoft always trusts itself) sometimes apps that did not get specifically microsoft certified could end up not being allowed.

Here is how you can create a admin account to test with or check to see if the account you use has high privilege.

I never user local user accounts, that’s just me. But the risk is a virus can hop on your system and enjoy itself. But some folks have a “writer” account and when they are in it they do not browse the internet or install stuff.