Multiple Instances of Dabble Open?

I looked, I didn’t see this but that doesn’t mean anything.

I’d like to be able to have two or more instances of Dabble open. Currently, I open two browsers, one to see my manuscript, one to see my plot grid. It kinda works until it goes to Sync. Then I get a message that Sync isn’t working. And then I get nervous my stuff won’t be saved. So is there a way to do this?

Does this work in the Desktop app? I can’t get that to install on my Samsung Note Galaxy.

1 Like

:face_with_monocle: Maybe then working offline would be best for you and syncing only when you take a longer break and close all but one instance before going back online and syncing again? (There is also always an up-to-date local copy.)
I thought it would be possible to turn off syncing by hand, which you could do for all but one instances, but I just checked and I couldn’t :).

Note: Mobile support is coming this summer.


I don’t recall having this problem before, but then again I usually have my documents open on different computers though I do recall trying to open it up. I wonder if it’s a newer issue than say one present before. I have been noticing it while beta testing. That I was having sync issues with multiple instances open.


Just to help with this testing I opened Dabble in four browser windows to the same section of a manuscript. As I added text into one browser the other three synchronized automatically within a few seconds. All of them showed the check mark inside the cloud icon. No warnings issued forth.

The web browser I use is Iridium, a fork of Chromium. My operating system is Ubuntu Linux 19.10.


It does work for awhile, maybe 15 minutes or so, and then it flips out. Not a huge issue but would be nice. I’ll try a different browser. That might help - thanks!

1 Like

I’ll mess with it some more. My tablet has a tablet/desktop toggle. yWriter, which I was using before I found Dabble, I had the issue if I was in tablet it wouldn’t work correctly. But when changed to desktop, it worked fine. Not sure if that helps or not. The error I’m getting is this app doesn’t work on your PC :frowning: All in all, it works fine. Just some things that would be nice - thanks!!

1 Like

I just finished testing four browser windows open to the same section of a scene, made occasional edits over the course of an hour, and other than suspending the sessions due to idle time, all four windows remained fully functional. Dabble is a rock. Again this is testing on Linux using Iridium, a fork of Chromium.

1 Like

My Alpha reader is using live and I’m using beta. She was missing revisions I’m had made and had to log out and log back in to get them. I’m using desktop and she was using the web app.

1 Like

Sorry for not responding sooner!

In the current version of Dabble, only one tab is responsible for syncing the data to the server. It should work fine. Hopefully the new version coming out next week works better. If not, I’ll spend some time improving it.

In the current version of Dabble, the one tab that is designated for syncing slows to a crawl when it is not visible, so be sure to close any Dabble tabs that are not visible while working in Dabble in case they are the current designated syncer. This issue is a problem with a 3rd party library I use for the data (from Google no less) that is throttled when not visible (it uses setTimeout, for those who know JavaScript). The new code gets rid of that library so I am able to control how syncing happens more fully. The update is much more efficient and faster.

@Tracy_Mason if you wouldn’t mind reporting back here in a couple weeks after you are able to try this on the new version coming out next Thursday, I would be most grateful. Thanks!

Jacob, thanks for the reply!!

I get it with the syncing. I really want to be able to use the desktop app. However, when I download for Windows I get this error:

Hopefully you can see the snip. It says there’s not an app associated. I have a Samsung Galaxy Book 2 tablet/PC which toggles between tablet & desktop.

The version I downloaded is 1.6.0 and it says it won’t run on my PC when I try to install it.

So, not sure if you an do anything about that. Regardless, I can use the web app and it’s fine and I’m happy.


1 Like

Apps nowadays are cryptographically signed with a purchased certificate. This is not unlike the secure connection you get in the browser on most websites now. Unfortunately, on Windows, it takes a few months to “break in” the new certificate. Once enough people have downloaded and installed the app without incident, Windows trusts the app developer.

The newest version (1.6.0) has a new certificate because we created a new company, Dabble LLC, last year after seeing Dabble was going to stick around. So this installer is still being “broken in”.

When you install it, you will get a message that says it can’t be trusted. You should find an option to “Install Anyway” or “Trust Anyway”. Choose that, install the app, and I promise not to send you any trojans or viruses. :smile:

Let me know if you get it working.

1 Like

I’m aware of the certificate issue, but that’s not what’s happening. I get past the run anyway and install it, but the install stops with the message in the Snip that I need a an app associated with it. How do I get past that?

Another software I used (not a web app) had some issues when in tablet mode. When I switched to desktop, it worked correctly. I tried both ways with Dabble and still getting the error message.

Is this on a Windows tablet? We haven’t done any testing or support for the desktop app on tablet devices.

I will be doing some extra testing on Windows today with the desktop install to see if I can figure this out.

Yes it’s a Windows tablet. Thank you!!

1 Like

Sounds like an OS issue.

@Tracy_Mason if it becomes an issue, you can install Dabble on your desktop like a regular app in Chrome, I’m not sure it’s doable at the present moment, but with the new version about to come out it most definitely is. It gets rid of the chrome chrome and looks like an app. But it’s the same as the webpage, but won’t give you that error you are seeing. The joy of progressive web apps :slight_smile:

1 Like

Rokay, I’ll try that. I got out my other laptop (not a tablet/laptop) and the desktop version works fine. I’ll let you know how it goes! Thanks so much for your help!

1 Like

It works for me so far. One one side of the screen I have my notecards. On the other, my manuscript.