Spell Check

How can I get the spell check to work properly? I have it set to the proper language (American English), but it insists that every single word I’ve typed is spelling incorrectly. Even basic words such as a, and, the, she, the… all marked as being incorrect.
Every single word in my document is underlined in red, and turning off spell check, switching languages, using enhanced spell check, etc., all fail to fix the problem.
It makes Dabble unusable to have every single word marked as a spelling mistake.

1 Like

Hey @Susan_Ellis! First, welcome. Second, I have no idea what is going on here. :astonished:

I’ll be looking into it. This isn’t happening for anyone else. You’re just special I guess! I’ll reach out to ProWritingAid. You can turn off spell check in the meantime so it doesn’t drive you crazy.

I just had a thought. Try switching your language to something else and saving it, then switching it back to English. Maybe that will fix it.

Hi Jacob,
I tried both of those options (turning it off and switching languages). Neither worked. I’m out of my house now but when I go home I’m going to see if signing out and in fixes the problem. Turning it off seems to be the go to method for fixing glitches.



Do you mean turning it off then back on didn’t fix it, or turning it off didn’t actually turn it off, and it still showed you spelling errors everywhere even when off?

Hi Jacob,
I meant that turning off the spell check didn’t stop the red lines from appearing.

Now I don’t have red lines, but I am also missing two chapters, and it won’t let me add any words beneath the chapter titles.

Okay, so I completely deleted everything and started over and I can at least add chapters now. I still have spelling errors marked for every word, however.

(The only words that do not have red marks are ones that I’ve physically added to the dictionary–obviously it’s not practical for me to go through and add every single word to the dictionary).

I reached out to ProWritingAid and they are looking into it. On my end, I set the language of my computer and browser to French Canadian in case there was an issue on my end, and it worked just fine, in your account. I also set the language to French within Dabble and got spelling errors as you would expect, but they all had suggested corrections, something you don’t get with whatever issue you are having.

My guess is that ProWritingAid has a few servers across the globe and you are closest (and therefore connecting) to one that has some issues. Because I can’t seem to replicate this issue with your exact setup. Hopefully they’ll figure it out soon.

If you want to get more aggressive in figuring this out with me, you can reach out directly in Help -> Chat with Support and we can screenshare and I can inspect the traffic from your browser for clues or errors.

Okay. Thank you for looking into it. Hopefully it’s something that will be corrected soon. Right now it’s only showing spelling errors (on every word) in some chapters, but other chapters look fine. Other than this issue, I’m loving Dabble. It’s really easy to use, very straightforward, and it has a lot of useful features.

1 Like

So, it’s been three months now, and I still have red lines under everything. Unless I physically add every single word to the dictionary it will be marked as a typo.

1 Like

I will reach out again to ProWritingAid to see what I might figure out. Sorry about this. It is such a strange one.

Thinking about it, the new update coming out routes the requests through our own server. This could fix whatever issues you have (avoiding sending cookies or hitting firewalls or whatever it might be).

1 Like

I have the opposite problem. Spell check doesn’t check any misspelled words, including things like kladj;fkdfjslkj that are really flagrant. Sometimes when I turn it on and off again it works, but when I quit and restart, it doesn’t underline misspelled words. Very frustrating. I’m thinking of just sticking with Novlr or Scrivener.

I am experiencing the same problem, sometimes spell check works and another time nothing. Very erratic behaviour.

1 Like

Everything is working perfectly now, very strange!

1 Like

I’m pleased that it’s working for you now. Things have improved slightly on my end, after much intervention on my part. My Spell Check is now underlining things again (it wasn’t for a while, despite me activating it). There are still some issues. For example, it does not underline “teh,” or auto-correct it to “the.” Unfortunately, typing out “teh” instead of “the” is a frequent mistake I make, and so there are several instances where “teh” appears in my manuscript without being underlined or auto-corrected. Too bad, because Dabble has excellent features and functions that are intuitive and helpful.

It is strange in that the behaviour is very inconsistent and doesn’t happen all the time. I’m wondering whether it’s something to do with the link between Dabble and the Pro Writing Aid servers who provide the spell and grammar checking.
I know it’s frustrating when this sort of thing happens, but I would stick with Dabble because it has as you say many excellent things going for it. Have you contacted them directly via the help menu? They are very responsive and can look at your account directly if you do so and will in my experience get to the bottom of it.
Dabble is still a new application relatively speaking and in my option has a great future ahead of it.

1 Like